Elevated Errors for Ashburn (IAD), New York (LGA), New York (NYC)

Incident
31 March 2026, 22:39 UTC

Elevated Errors for Ashburn (IAD), New York (LGA), New York (NYC)

Status: closed
Start: 31 March 2026, 22:24 UTC
End: 31 March 2026, 22:39 UTC
Duration: 15 minutes
Affected Components:
Platform North America New York (NYC) New York (LGA) Ashburn (IAD)
Affected Groups:
All Public Users
Investigating

31 March 2026, 22:24 UTC

31 March 2026, 22:24 UTC

We are investigating elevated errors to our Ashburn (IAD), New York (LGA), New York (NYC) (service/Point of Presence (POP)).

All other products and services are unaffected by this incident.

Identified

31 March 2026, 22:28 UTC

31 March 2026, 22:28 UTC

Our engineers have identified  (an/a)   (additional or different)  contributing factor and are developing an adjusted mitigation strategy to Ashburn (IAD), New York (LGA), New York (NYC)  (service/POP)  .

(All other locations and services are unaffected.)

Identified

31 March 2026, 22:31 UTC

31 March 2026, 22:31 UTC

Our engineers believe they have identified contributing factor causing the issue impacting the   Ashburn (IAD), New York (LGA), New York (NYC) status page component  .

We are now developing a fix, and will post a new update once it has been fully implemented and we see signs of recovery.

All other products and services are unaffected by this incident.

Monitoring

31 March 2026, 22:32 UTC

31 March 2026, 22:32 UTC

Engineering has confirmed the impact to Ashburn (IAD), New York (LGA), New York (NYC) (service/POP) has been mitigated.

Resolved

31 March 2026, 22:39 UTC

31 March 2026, 22:39 UTC

During this incident, customers may have experienced elevated errors and timeouts from 8:55 to 10:30 UTC.

This incident is resolved.

For more information about this retrospective stat us post, please reach out to Support through https://support.fastly.com .