Elevated Errors for API Services

Incident
17 March 2026, 04:07 UTC

Elevated Errors for API Services

Status: closed
Start: 17 March 2026, 02:00 UTC
End: 17 March 2026, 04:07 UTC
Duration: 2 hours 7 minutes
Affected Components:
Fastly Fastly Application API & Configuration Management API Services Configuration Management Services
Affected Groups:
All Public Users
Investigating

17 March 2026, 02:00 UTC

17 March 2026, 02:00 UTC

We are investigating elevated errors to our API Services

All other products and services are unaffected by this incident.

Identified

17 March 2026, 03:35 UTC

17 March 2026, 03:35 UTC

Our engineers believe they have identified contributing factor causing the issue impacting the   API Services status page component  .

We are now developing a fix, and will post a new update once it has been fully implemented and we see signs of recovery.

All other products and services are unaffected by this incident.

Monitoring

17 March 2026, 04:06 UTC

17 March 2026, 04:06 UTC

Engineering has deployed a fix and have confirmed a gradual recovery to API Services . We will continue to monitor until we’ve confirmed that customer experience has been fully restored.

Resolved

17 March 2026, 04:07 UTC

17 March 2026, 04:07 UTC

This event has been resolved.

To offer feedback on our status page, click "Give Feedback".