Ashburn (IAD) Maintenance

Maintenance
16 March 2026, 12:00 UTC

Ashburn (IAD) Maintenance

Status: closed
Start: 16 March 2026, 08:00 UTC
End: 16 March 2026, 12:00 UTC
Duration: 4 hours
Affected Components:
Platform North America Ashburn (IAD)
Affected Groups:
All Public Users
Update

16 March 2026, 08:00 UTC

16 March 2026, 08:00 UTC

Fastly will be performing scheduled maintenance on our Ashburn (IAD) data center from 16 March 2026, 08:00 UTC - 16 March 2026, 12:00 UTC.

During this time frame traffic will be redirected to neighboring POPs in the region.

Resolved

16 March 2026, 12:00 UTC

16 March 2026, 12:00 UTC

The scheduled maintenance has been completed.

To offer feedback on our status page, click "Give Feedback